

    
      
          
            
  
Welcome to Read the Docs

This is an autogenerated index file.

Please create an index.rst or README.rst file with your own content
under the root (or /docs) directory in your repository.

If you want to use another markup, choose a different builder in your settings.
Check out our Getting Started Guide [https://docs.readthedocs.io/en/latest/getting_started.html] to become more
familiar with Read the Docs.
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fpga-drive-aximm-pcie

This repo contains the example designs for the FPGA Drive FMC mated with several FPGA and MPSoC evaluation boards.

![FPGA Drive FMC](http://fpgadrive.com/wp-content/uploads/2018/10/fpga-drive-fmc-3.jpg “FPGA Drive FMC”)

## Requirements

This project is designed for version 2019.2 of the Xilinx tools (Vivado/Vitis/PetaLinux).
If you are using an older version of the Xilinx tools, then refer to the
[release tags](https://github.com/fpgadeveloper/fpga-drive-aximm-pcie/releases “releases”)
to find the version of this repository that matches your version of the tools.

In order to test this design on hardware, you will need the following:


	Vivado 2019.2


	Vitis 2019.2


	PetaLinux SDK 2019.2


	[FPGA Drive](http://fpgadrive.com “FPGA Drive”) - for connecting a PCIe SSD


	M.2 PCIe Solid State Drive


	One of the supported carriers listed below




## Supported carrier boards


	Zynq-7000 [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”) with [PicoZed 7015/30](http://picozed.org “PicoZed”)
* PCIe edge - Single SSD
* LPC connector - Single SSD


	Kintex-7 [KC705 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-k7-kc705-g.html “KC705 Evaluation board”)
* PCIe edge - Single SSD
* LPC connnector - Single SSD
* HPC connnector - Single SSD


	Kintex Ultrascale [KCU105 Evaluation board](http://www.xilinx.com/products/boards-and-kits/kcu105.html “KCU105 Evaluation board”)
* LPC connnector - Single SSD
* HPC connnector - Single and Dual SSD designs


	Virtex-7 [VC707 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-v7-vc707-g.html “VC707 Evaluation board”)
* PCIe edge (use vc707.xdc)
* HPC connector 1 - Single SSD
* HPC connector 2 - Single SSD


	Virtex-7 [VC709 Evaluation board](http://www.xilinx.com/products/boards-and-kits/dk-v7-vc709-g.html “VC709 Evaluation board”)
* PCIe edge - Single SSD
* HPC connector - Single SSD


	Zynq-7000 [ZC706 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc706-g.html “ZC706 Evaluation board”)
* PCIe edge - Single SSD
* LPC connector - Single SSD
* HPC connector - Single SSD


	Zynq UltraScale+ MPSoC [ZCU104 Evaluation board](https://www.xilinx.com/products/boards-and-kits/zcu104.html “ZCU104 Evaluation board”)
* LPC connector - Single SSD


	Zynq UltraScale+ MPSoC [ZCU106 Evaluation board](https://www.xilinx.com/products/boards-and-kits/zcu106.html “ZCU106 Evaluation board”)
* HPC connector 0 - Single and Dual SSD designs
* HPC connector 1 - Single SSD


	Zynq UltraScale+ RFSoC [ZCU111 Evaluation board](https://www.xilinx.com/products/boards-and-kits/zcu111.html “ZCU111 Evaluation board”)
* FMC+ connector - Single and Dual SSD designs




## Description

These are the example designs for the FPGA Drive and FPGA Drive FMC adapters that allow connecting
NVMe SSDs to FPGAs via PCIe edge connectors and FPGA Mezzanine Card (FMC) connectors.

The bare metal software application reports on the status of the PCIe link and
performs enumeration of the detected PCIe end-points (ie. the SSDs). The project also contains
scripts to generate PetaLinux for these platforms to allow accessing the SSDs from the Linux
operating system.

### Single SSD designs

![FPGA Drive FMC single load](http://fpgadrive.com/wp-content/uploads/2018/10/fpga-drive-fmc-single-load.jpg “FPGA Drive FMC single load”)

The projects in this repo without the “_dual” postfix are intended to be used with only one loaded SSD as
shown in the above image. The SSD should be loaded into the first M.2 slot, labelled SSD1. If you are using
the older version FPGA Drive FMC (Rev-B) with only one M.2 connector, you will only be able to use the single SSD designs.

### Dual SSD designs

![FPGA Drive FMC dual load](http://fpgadrive.com/wp-content/uploads/2018/10/fpga-drive-fmc-dual-load.jpg “FPGA Drive FMC dual load”)

The projects in this repo with the “_dual” postfix are intended to be used with two loaded SSDs as shown
in the above image. The dual designs may not function as expected if only one SSD is loaded. If you are using the
older version FPGA Drive FMC (Rev-B) with only one M.2 connector, you will not be able to use the dual designs.

At the moment there are dual designs for these carriers:
* KCU105
* ZCU106
* ZCU111

### Build instructions

To use the sources in this repository, please follow these steps:

### Windows users


	Download the repo as a zip file and extract the files to a directory
on your hard drive –OR– Git users: clone the repo to your hard drive


	Open Windows Explorer, browse to the repo files on your hard drive.


	In the Vivado directory, you will find multiple batch files (*.bat).
Double click on the batch file that is appropriate to your hardware,
for example, double-click build-zedboard.bat if you are using the ZedBoard.
This will generate a Vivado project for your hardware platform.


	Run Vivado and open the project that was just created.


	Click Generate bitstream.


	When the bitstream is successfully generated, select File->Export->Export Hardware.
In the window that opens, tick “Include bitstream” and “Local to project”.


	Return to Windows Explorer and browse to the Vitis directory in the repo.


	Double click the build-vitis.bat batch file. The batch file will run the
build-vitis.tcl script and build the Vitis workspace containing the hardware
design and the software application.


	Run Xilinx Vitis and select the workspace to be the Vitis directory of the repo.


	Connect and power up the hardware.


	Open a Putty terminal to view the UART output.


	In Vitis, select Xilinx Tools->Program FPGA.


	Right-click on the application and select Run As->Launch on Hardware (Single Application Debug)




### Linux users


	Download the repo as a zip file and extract the files to a directory
on your hard drive –OR– Git users: clone the repo to your hard drive


	Launch the Vivado GUI.


	Open the Tcl console from the Vivado welcome page. In the console, cd to the repo files
on your hard drive and into the Vivado subdirectory. For example: cd /media/projects/fpga-drive-aximm-pcie/Vivado.





	In the Vivado subdirectory, you will find multiple Tcl files. To list them, type exec ls {*}[glob *.tcl].
Determine the Tcl script for the example project that you would like to generate (for example: build-zcu104.tcl),
then source the script in the Tcl console: For example: source build-zcu104.tcl


	Vivado will run the script and generate the project. When it’s finished, click Generate bitstream.


	When the bitstream is successfully generated, select File->Export->Export Hardware.
In the window that opens, tick “Include bitstream” and “Local to project”.


	To build the Vitis workspace, open a Linux command terminal and cd to the Vitis directory in the repo.


	The Vitis directory contains the build-vitis.tcl script that will build the Vitis workspace containing the hardware design and
the software application. Run the build script by typing the following command:
<path-of-xilinx-vitis>/bin/xsct build-vitis.tcl. Note that you must replace <path-of-xilinx-vitis> with the
actual path to your Xilinx Vitis installation.


	Run Xilinx Vitis and select the workspace to be the Vitis subdirectory of the
repo.


	Connect and power up the hardware.


	Open a Putty terminal to view the UART output.


	In Vitis, select Xilinx Tools->Program FPGA.


	Right-click on the application and select Run As->Launch on Hardware (Single Application Debug)




## Stand-alone software application

A stand-alone software application can be built for this project using the build script contained in the Vitis subdirectory
of this repo. The build script creates a Vitis workspace containing the hardware platform (exported from Vivado) and a stand-alone
application. The application originates from an example provided by Xilinx which is located in the Vitis installation files.
The program demonstrates basic usage of the stand-alone driver including how to check link-up, link speed, the number of
lanes used, as well as how to perform PCIe enumeration. The original example applications can be found here:


	For the AXI PCIe designs:




C:XilinxVitis2019.2dataembeddedswXilinxProcessorIPLibdriversaxipcie_v3_1examplesxaxipcie_rc_enumerate_example.c
* For the XDMA designs:
C:XilinxVitis2019.2dataembeddedswXilinxProcessorIPLibdriversxdmapcie_v1_0examplesxdmapcie_rc_enumerate_example.c

## PetaLinux

This repo contains a script and configuration files for a PetaLinux project for each one of the hardware platforms. To build
the PetaLinux project, please refer to the “README.md” file in the PetaLinux subdirectory of this repo.

## Board Specific Notes

### KCU105


	To keep these designs free of paid IP, the KCU105’s on-board Ethernet port is not connected in this design. The




KCU105’s Ethernet PHY has an SGMII interface which is not supported by the free AXI EthernetLite IP.

### VC709 and KCU105

These designs are based on the [AXI Bridge for PCI Express Gen3 Subsystem](http://www.xilinx.com/support/documentation/ip_documentation/axi_pcie3/v3_0/pg194-axi-bridge-pcie-gen3.pdf “AXI Bridge for PCI Express Gen3 Subsystem v3.0”)
. To generate an example stand-alone application for these boards,
the Vitis build script makes a local copy of the driver for the [AXI Memory Mapped to PCIe Gen2 IP](https://www.xilinx.com/products/intellectual-property/axi_pcie.html “AXI Memory Mapped to PCIe Gen2 IP”)
with a few small modifications to make it work with the Gen3 core. If you use or modify these applications, be aware
that they refer to the locally copied and modified driver located in EmbeddedSw/XilinxProcessorIPLib/drivers, and that
that driver is actually designed for the Gen2 core. In other words, you can expect the driver to work for the example
application that checks link-up, link speed/width and enumerates the end points, but anything else may fail due to
differences between the driver code and the Gen3 IP specs.

### PicoZed

#### Installation of PicoZed board definition files

To use this project on the PicoZed, you must first install the board definition files
for the PicoZed into your Vivado installation.

The following folders contain the board definition files and can be found in this project repository at this location:

https://github.com/fpgadeveloper/fpga-drive-aximm-pcie/tree/master/Vivado/boards/board_files


	picozed_7015_fmc2


	picozed_7030_fmc2




Copy those folders and their contents into the C:XilinxVivado2019.2databoardsboard_files folder (this may
be different on your machine, depending on your Vivado installation directory).

### PicoZed FMC Carrier Card V2

On this carrier, the GBTCLK0 of the LPC FMC connector is routed to a clock synthesizer/MUX, rather than being directly
connected to the Zynq. In order to use the FPGA Drive FMC on the [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”),
you will need to reconfigure the clock synthesizer so that it feeds the FMC clock through to the Zynq. To change the configuration,
you must reprogram the EEPROM (U14) where the configuration is stored. Avnet provides an SD card boot file that can be run to
reprogram the EEPROM to the configuration we need for this project. The boot files have been copied to the links below for your
convenience:


	[PicoZed 7015 BOOT.bin for FMC clock config](https://opsero.com/downloads/picozed/pz_7015_fmc_clock.zip “PicoZed 7015 BOOT.bin for FMC clock config”)


	[PicoZed 7030 BOOT.bin for FMC clock config](https://opsero.com/downloads/picozed/pz_7030_fmc_clock.zip “PicoZed 7030 BOOT.bin for FMC clock config”)




Just boot up your [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”)
using one of those boot files, and the EEPROM will be reprogrammed as required for this project. For more information,
see the [Hardware User Guide](http://zedboard.org/sites/default/files/documentations/5285-UG-PZCC-FMC-V2-V1_1.pdf “Hardware User Guide”)
for the [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”).

### ZCU106

The ZCU106 has two HPC FMC connectors, HPC0 and HPC1. The HPC0 connector has enough connected gigabit transceivers to support
2x SSDs, each with an independent 4-lane PCIe interface. The HPC1 connector has only 1x connected gigabit transceiver, so it can only
support 1x SSD (SSD1) with a 1-lane PCIe interface. This repo contains designs for both of these connectors.

### ZCU111

The ZCU111 has a single FMC+ connector that can support 2x SSDs, each with an independent 4-lane PCIe interface.

## Troubleshooting

Check the following if the project fails to build or generate a bitstream:

### 1. Are you using the correct version of Vivado for this version of the repository?
Check the version specified in the Requirements section of this readme file. Note that this project is regularly maintained to the latest
version of Vivado and you may have to refer to an earlier commit of this repo if you are using an older version of Vivado.

### 2. Did you follow the Build instructions in this readme file?
All the projects in the repo are built, synthesised and implemented to a bitstream before being committed, so if you follow the
instructions, there should not be any build issues.

### 3. Did you copy/clone the repo into a short directory structure?
Vivado doesn’t cope well with long directory structures, so copy/clone the repo into a short directory structure such as
`C:projects`. When working in long directory structures, you can get errors relating to missing files, particularly files
that are normally generated by Vivado (FIFOs, etc).

## Contribute

We encourage contribution to these projects. If you spot issues or you want to add designs for other platforms, please
make a pull request.

### About us

This project was developed by [Opsero Inc.](http://opsero.com “Opsero Inc.”),
a tight-knit team of FPGA experts delivering FPGA products and design services to start-ups and tech companies.
Follow our blog, [FPGA Developer](http://www.fpgadeveloper.com “FPGA Developer”), for news, tutorials and
updates on the awesome projects we work on.





            

          

      

      

    

  

    
      
          
            
  
PetaLinux Project source files

### How to build the PetaLinux projects

#### Requirements


	Windows or Linux PC with Vivado installed


	Linux PC or virtual machine with PetaLinux installed




#### Instructions

In order to make use of these source files, you must:


	First generate the Vivado project hardware design(s) (the bitstream) and export the design(s) to SDK.


	Launch PetaLinux by sourcing the settings.sh bash script, eg: source <path-to-installed-petalinux>/settings.sh


	Build the PetaLinux project(s) by executing the build-petalinux script in Linux.




The script will generate a separate PetaLinux project for all of the generated and exported Vivado projects that
it finds in the Vivado directory of this repo.

### UNIX line endings

The scripts and files in the PetaLinux directory of this repository must have UNIX line endings when they are
executed or used under Linux. The best way to ensure UNIX line endings, is to clone the repo directly onto your
Linux machine. If instead you have copied the repo from a Windows machine, the files will have DOS line endings and
you must use the dos2unix tool to convert the line endings for UNIX.


	Copy the cloned repository from your Windows machine to your Linux machine.


	Use the cd command to navigate to the copied repository on your Linux machine.




3. Type find . -type f -exec dos2unix –keepdate {} + to convert all of the files
to the Unix format.

### How the script works

The PetaLinux directory contains a build-petalinux shell script which can be run in Linux to automatically
generate a PetaLinux project for each of the generated/exported Vivado projects in the Vivado directory.

When executed, the build script searches the Vivado directory for all projects containing a .xsa exported
hardware design file. Then for every exported project, the script does the following:


	Verifies that the .bit file exists.




2. Determines the CPU type: Microblaze, Zynq or ZynqMP. It currently does this
by looking at the first 3 letters of the project name.
3. Creates a PetaLinux project, referencing the exported hardware design (.xsa).
4. Copies the relevant configuration files from the src directory into the created
PetaLinux project.
5. Builds the PetaLinux project.
6. Generates a BOOT.bin and image.ub files for the Zynq projects.

### Launch PetaLinux on hardware

#### Via JTAG

To launch the PetaLinux project on hardware via JTAG, connect and power up your hardware and then
use the following commands in a Linux command terminal:

1. Change current directory to the PetaLinux project directory:
cd <petalinux-project-dir>
2. Download bitstream to the FPGA:
petalinux-boot –jtag –fpga –bitstream ./images/linux/system.bit
If you don’t use the –bitstream option to specify the bitstream, then PetaLinux will download the
./images/linux/download.bit bitstream containing the FSBL. We don’t want to run the FSBL when
booting via JTAG.
3. Download the PetaLinux kernel to the FPGA:
petalinux-boot –jtag –kernel

#### Via SD card (Zynq and ZynqMP)

To launch the PetaLinux project on hardware via SD card, copy the following files to the root of the
SD card:


	/<petalinux-project>/images/linux/BOOT.bin


	/<petalinux-project>/images/linux/image.ub




Then connect and power your hardware.

### Kernel Start Address for AXI PCIe Gen3 Subsystem

The AXI PCIe Gen3 Subsystem requires it’s CTL0 interface to be allocated 256MB on the address map.
During Linux boot, vmalloc is used to allocate virtual memory for this interface. This repo configures
the Kernel start address to 0xB0000000 from the default 0xC0000000, in order to create sufficient
virtual memory for the CTL0 interface. Without this modification, vmalloc fails during boot.

Find the modification here:

PetaLinux/src/axi_pcie3/project-spec/meta-user/recipes-kernel/linux/linux-xlnx/kernel-options.cfg

### Known Issues

#### KCU105 Dual design fails to boot when one or both SSDs are not connected

In the case where only one or neither SSD is connected, the PetaLinux boot freezes during the PCIe
enumeration. For example, if we connect SSD1 but not SSD2, PetaLinux boot stops after the following
lines:

`
xilinx-pcie 10000000.axi-pcie: PCIe Link is UP
xilinx-pcie 10000000.axi-pcie: host bridge /amba_pl/axi-pcie@10000000 ranges:
xilinx-pcie 10000000.axi-pcie:   MEM 0x60000000..0x6fffffff -> 0x60000000
xilinx-pcie 10000000.axi-pcie: PCI host bridge to bus 0000:00
pci_bus 0000:00: root bus resource [bus 00-ff]
pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
pci 0000:00:00.0: [10ee:8134] type 01 class 0x060400
pci 0000:00:00.0: reg 0x38: [mem 0x00000000-0x000007ff pref]
pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
pci 0000:01:00.0: [144d:a808] type 00 class 0x010802
pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x00003fff 64bit]
pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
pci 0000:00:00.0: BAR 6: assigned [mem 0x60100000-0x601007ff pref]
pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x60003fff 64bit]
pci 0000:00:00.0: PCI bridge to [bus 01]
pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
xilinx-pcie 20000000.axi-pcie: PCIe Link is DOWN
xilinx-pcie 20000000.axi-pcie: host bridge /amba_pl/axi-pcie@20000000 ranges:
xilinx-pcie 20000000.axi-pcie:   MEM 0x70000000..0x7fffffff -> 0x70000000
xilinx-pcie 20000000.axi-pcie: PCI host bridge to bus 0001:00
pci_bus 0001:00: root bus resource [bus 00-ff]
pci_bus 0001:00: root bus resource [mem 0x70000000-0x7fffffff]
pci 0001:00:00.0: [10ee:8134] type 01 class 0x060400
`

We suspect that this is caused by a mishandling of the “PCIe Link is DOWN” case by the AXI PCIe
driver. The correct behavior should be that the enumeration is skipped and boot continues when the
down link is detected.

It is worth noting that our ZCU102 Dual design does NOT fail to boot under these conditions,
suggesting that the XDMA driver IS designed to properly handle the “PCIe Link is DOWN” case.
We are still looking for a solution to this issue.





            

          

      

      

    

  

    
      
          
            
  
Vitis Project files

### Important patch for Vitis 2019.2

To use the build script in this directory, you must first apply the following patch
to your Vitis installation:

https://www.xilinx.com/support/answers/73252.html

### How to build the Vitis workspace

In order to make use of these source files, you must first generate
the Vivado project hardware design (the bitstream) and export the hardware.
Check the Vivado folder for instructions on doing this from Vivado.

Once the bitstream is generated and exported, then you can build the
Vitis workspace using the provided build-vitis.tcl script.

### Scripted build

The Vitis directory contains a build-vitis.tcl script which can be run to automatically
generate the Vitis workspace. Windows users can run the build-vitis.bat file which
launches the Tcl script. Linux users must use the following commands to run the build
script:
`
cd <path-to-repo>/Vitis
/<path-to-xilinx-tools>/Vitis/2019.2/bin/xsct build-vitis.tcl
`

The build script does three things:

1. Makes a copy of the axipcie driver from
`{Vitis Install Dir}dataembeddedswXilinxProcessorIPLibdrivers` to the repo’s local
directory `EmbeddedSwXilinxProcessorIPLibdrivers`. Files that are already there
as part of the repo are not overwritten, which allows us to keep a modified version
of the driver. This modified version of the driver is used by the projects using the
Gen3 core (AXI Bridge for PCIe Gen3 IP). See below for more information.
2. Generates an empty application for each exported Vivado design
that is found in the ../Vivado directory. Most users will only have one exported
Vivado design.
3. Copies the appropriate enumeration application source file from the
`Vitiscommonsrc` directory of this repo into the application source directory.

### Run the application


	Open Xilinx Vitis.




2. Power up your hardware platform and ensure that the JTAG is
connected properly.
3. In the Vitis Explorer panel, double-click on the System project that you want to run -
this will reveal the applications contained in the project. The System project will have
the postfix “_system”.
4. Now click on the application that you want to run. It should have the postfix “_ssd_test”.
5. Select the option “Run Configurations” from the drop-down menu contained under the Run
button on the toolbar (play symbol).
6. Double-click on “Single Application Debug” to create a run configuration for this
application. Then click “Run”.

The run configuration will first program the FPGA with the bitstream, then load and run the
application. You can view the UART output of the application in a console window.

### UART settings

To receive the UART output of this standalone application, you will need to connect the
USB-UART of the development board to your PC and run a console program such as
[Putty](https://www.putty.org “Putty”). The follow UART settings must be used:


	Microblaze designs: 9600 baud


	Zynq and ZynqMP designs: 115200 baud




### Linker script modifications for Zynq designs

For the Zynq designs, the Vitis’s linker script generator automatically assigns all sections
to the BAR0 memory space, instead of assigning them to the DDR memory space. This causes
failure of the application to run, when booted from SD card or JTAG. To overcome this problem,
the Vitis build script modifies the generated linker script and correctly assigns the sections
to DDR memory.

If you want to manually create an application in the Vitis for one of the Zynq designs,
you will have to manually modify the automatically generated linker script, and set all sections
to DDR memory.

### Driver for AXI Bridge for PCIe Gen3 IP

Some of the Vivado designs in this project use the AXI Memory Mapped to PCIe Gen2 IP
and others use the AXI Bridge for PCIe Gen3 IP. Vitis comes with a driver for the Gen2
core that is called axipcie. The BSPs for projects using the Gen2 core refer to that
driver. You can find the driver sources in the Vitis installation files:

`{Vitis Install Dir}dataembeddedswXilinxProcessorIPLibdrivers`

The Vitis does not currently supply a driver for the Gen3 core, so we have to create our
own. Luckily, there are enough similarities between the Gen2 and Gen3 cores that we can
get away with using a modified version of the axipcie driver on the Gen3 core. This
will allow us to do some simple things such as link-up detection, determining link speed
and width, and enumerating PCIe devices.

We create this “Gen3 version” of the driver by making a local copy of the axipcie driver
sources and modifying the .mdd file, specifying that the driver supports the Gen3 core.
For Vitis to be aware of our locally copied driver, we set the Vitis’s repository path to the path
of the driver. The build-sdk.tcl script handles the copying and modification of the
axipcie driver, which is stored locally in the EmbeddedSw/XilinxProcessorIPLib/drivers
directory.
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